Kortsluiting probe op board (+/-) autolevel + nieuwe firmware.

Vragen over het gebruik van de printer, toepassingen etc.
DennisK
Berichten: 50
Lid geworden op: 01 jan 2019, 23:28
Contacteer:

Re: Kortsluiting probe op board (+/-) autolevel + nieuwe firmware.

Bericht door DennisK » 02 jan 2019, 13:48

Voorstellen zal ik zeker nog even doen. Zag de topic al staan.


Inmiddels nogmaals geprobeerd met de basic kossel mini delta config vanuit de configurator met zo min mogelijk aanpassingen maar helaas hij heeft er geen zin in.

Dan toch maar eerst oudere proberen.
Is altijd nog nieuwer dan ik nu heb.

Wil wat meer opties in mn menu.
Z bijstellen en eventueel een calibratie procedure.

DennisK
Berichten: 50
Lid geworden op: 01 jan 2019, 23:28
Contacteer:

Re: Kortsluiting probe op board (+/-) autolevel + nieuwe firmware.

Bericht door DennisK » 04 jan 2019, 23:11

Hoi,

Ik heb Marlin 1.1.5 er inmiddels in gekregen. Deze werkt wel.
Autocalibratie G33 met wat bijregelen van de probe offset werkt uiteindelijk.

Maar de Bed leveling doet het niet.

Zodra ik G28 doe reset de printer zichzelf.

Ik denk dat ik ergens iets over het hoofd zie in de codes.

Waar ik mee zit.

#define Z_MIN_PROBE_USES_Z_MIN_ENDSTOP_PIN
Staat als standaard. Dit werkt met auto kalibratie.
Maar heb dus een allen key probe.

Als ik deze aan zet krijg ik dat ik geen dubbele functie aan mag.
Dus zet ik de boven genoemde uit.
Dan werkt auto kalibratie niet meer.
Gaat dan ergens op 150mm de hoek in. Reageerde nog wel een keer op de probe
/**
* Z_MIN_PROBE_USES_Z_MIN_ENDSTOP_PIN
*
* Enable this option for a probe connected to the Z Min endstop pin.
*/
#define Z_MIN_PROBE_USES_Z_MIN_ENDSTOP_PIN

/**
* Z_MIN_PROBE_ENDSTOP
*
* Enable this option for a probe connected to any pin except Z-Min.
* (By default Marlin assumes the Z-Max endstop pin.)
* To use a custom Z Probe pin, set Z_MIN_PROBE_PIN below.
*
* - The simplest option is to use a free endstop connector.
* - Use 5V for powered (usually inductive) sensors.
*
* - RAMPS 1.3/1.4 boards may use the 5V, GND, and Aux4->D32 pin:
* - For simple switches connect...
* - normally-closed switches to GND and D32.
* - normally-open switches to 5V and D32.
*
* WARNING: Setting the wrong pin may have unexpected and potentially
* disastrous consequences. Use with caution and do your homework.
*
*/
//#define Z_MIN_PROBE_ENDSTOP

/**
* Probe Type
*
* Allen Key Probes, Servo Probes, Z-Sled Probes, FIX_MOUNTED_PROBE, etc.
* Activate one of these to use Auto Bed Leveling below.
*/


/**

iemand een hint waar ik het 1 en ander moet nakijken.
Zelf nog niet aan toe gekomen om het uit te zoeken.

Zal nog vast meer issues tegen komen.
Maar heb net alweer een 20mm kubus geprint.

Als dit werkt probeer ik nog naar nieuwere firmware door te gaan maar dan heb ik een betere basis.
Volgensmij zit er echt iets niet goed in de 1.1.9 delta templates. 1.1.5. Zag er toch anders uit.

DennisK
Berichten: 50
Lid geworden op: 01 jan 2019, 23:28
Contacteer:

Re: Kortsluiting probe op board (+/-) autolevel + nieuwe firmware.

Bericht door DennisK » 05 jan 2019, 12:41

Hij doet het al denk ik.

Weet niet precies wat. maar hij moet in ieder geval op #define Z_MIN_PROBE_USES_Z_MIN_ENDSTOP_PIN blijven staan.

Als ik hem naar alen key zet dan bumpted hij niet meer op Z bij auto home.

Heb alleen de leveling van Lineair naar #define AUTO_BED_LEVELING_BILINEAR gezet.

Hij start wel raar maar dat zal de deploy wel zijn.
Moet dit handmatig doen. Kan even iet anders.
Bij stow moet ik hem snel zelf weer omhoog zetten anders krijg ik een err: ZPROBE


Ik ga weer even verder rommelen, kijken of het werkt / beter kan.


Edit:
Viel mij op dat Fr LCD feedrate niet werkt tijdens het printen. Voor het printen nog wel maar nog niet gecontroleerd of dit wel invloex heeft aangezien ik gelezen heb dat er meer problemen zijn.
Maar de bugfix heb ik nog niet gevonden...

https://github.com/MarlinFirmware/Marlin/issues/7905


Edit 2:

Heb een kleine afwijking in XY as.
Kubus hoogte is 20mm
Maar XY is ongeveer 19,85mm

Geprobeerd Rod lengte 1mm korter te maken en kalibratie opnieuw te doen maar helaas.

De M code M579 werkt niet. Hier mee zou je XY moeten kunnen verschalen.

Iemand meer opties?

Testje Marlin 1.1.5 (kiss slicer)

Afbeelding

DennisK
Berichten: 50
Lid geworden op: 01 jan 2019, 23:28
Contacteer:

Re: Kortsluiting probe op board (+/-) autolevel + nieuwe firmware.

Bericht door DennisK » 06 jan 2019, 18:45

Zo weer een dagje verder maar jaja heb Marlin 1.1.9 er nu werkend in.

Naar mijn idee werkt de configurator niet of ik snap heb niet ;)

Nu losse marlin 1.1.9 zip gedownload.
Daar eerste de basis delta kossel mini config/configadv. Gekopieerd.

1.1.9 en 1.1.5 naast elkaar gezet en weer door de bestanden heen gespit.

Paar kleine issues maar meeste werkt nu wel weer.

Nog even kijken hoe die bed level grid nou werkt.
Heb nu heel veel punten. Snelheid mag hoger en lijkt niet het grid in het midden te hebben. Maar kan zo lijken door de probe offset. (dat hij deze zelf later in calculeert.

Algemene print snelheid is ineens lager dus hier ook nog kijken wat de oorzaak is.
Retract/prime speed van de extruder was ineens weer te hoog. Slipte bij het heen en weer gaan.

Fr rotary knop werkt bij 1.1.9 in ieder geval weer tijdens het printen

Bed level zou ook beter moeten kunnen.

XY vs Z afwijking is nog hetzelfde. De M579 nog niet geprobeerd.

Nog beetje rommelen om nog wat fouten op te sporen en hopelijk op te lossen.

DennisK
Berichten: 50
Lid geworden op: 01 jan 2019, 23:28
Contacteer:

Re: Kortsluiting probe op board (+/-) autolevel + nieuwe firmware.

Bericht door DennisK » 07 jan 2019, 18:37

Maar weer even een update.
Letterlijk en figuurlijk.

Gisteren tijd bezig geweest maar zinde mij niet.
Hij hapert in zijn grote bewegingen bij een test printje.
En de reactie op snelheid is gewoon ineens anders. Maar rommelen met de instelling doet weinig.
1.1.5. Had ik vrij snel weer goed printend.

Dus vandaag met enige twijfel toch maar eens Github marlin 1.1.9 (1.1.X) bugfix versie erop gezet.

Helaas zie ik daar geen verbeteringen tot nu toe.
Misschien toch maar 1.1.7 of 1.1.8 ook eens proberen. En in iedergeval even 1.1.5 even terug zetten om hardware problemen uit te sluiten.

Of misschien reageert mijn slicer software ook wel wat anders icm firmware dan ik gewend ben.

Heb mn lineaire lagers schoongemaakt. 1tje misschien toch nog maar eens vervangen. Loopt minder soepel dan de rest. Was al bij aankoop.

Schiet allemaal niet echt op zo maar je wordt er zelf goed in zo om alles weer eens door te spitten.

Plaats reactie

Wie is er online

Gebruikers op dit forum: 3Dwim en 1 gast